Page 2 of 2

Re: Error installing report_openoffice

PostPosted: Tue Feb 02, 2010 3:37 pm
by rbonazzo
Hi to all,
I'm trying to install report_openoffice following the instruction and the thread solution but receive the following error
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/openerp-server/netsvc.py", line 244, in dispatch
result = LocalService(service_name)(method, *params)
File "/usr/lib/python2.5/site-packages/openerp-server/netsvc.py", line 73, in __call__
return getattr(self, method)(*params)
File "/usr/lib/python2.5/site-packages/openerp-server/service/web_services.py", line 639, in execute
return self._execute(db, uid, wiz_id, datas, action, context)
File "/usr/lib/python2.5/site-packages/openerp-server/service/web_services.py", line 619, in _execute
return wiz.execute(db, uid, self.wiz_datas[wiz_id], action, context)
File "/usr/lib/python2.5/site-packages/openerp-server/wizard/__init__.py", line 178, in execute
res = self.execute_cr(cr, uid, data, state, context)
File "/usr/lib/python2.5/site-packages/openerp-server/wizard/__init__.py", line 74, in execute_cr
action_res = action(self, cr, uid, data, context)
File "/usr/lib/python2.5/site-packages/openerp-server/addons/base/module/wizard/wizard_module_upgrade.py", line 92, in _upgrade_module
db, pool = pooler.restart_pool(cr.dbname, update_module=True)
File "/usr/lib/python2.5/site-packages/openerp-server/pooler.py", line 62, in restart_pool
return get_db_and_pool(db_name, force_demo, status, update_module=update_module)
File "/usr/lib/python2.5/site-packages/openerp-server/pooler.py", line 40, in get_db_and_pool
addons.load_modules(db, force_demo, status, update_module)
File "/usr/lib/python2.5/site-packages/openerp-server/addons/__init__.py", line 728, in load_modules
r = load_module_graph(cr, graph, status, report=report)
File "/usr/lib/python2.5/site-packages/openerp-server/addons/__init__.py", line 578, in load_module_graph
register_class(package.name)
File "/usr/lib/python2.5/site-packages/openerp-server/addons/__init__.py", line 400, in register_class
imp.load_module(m, *fm)
File "/usr/lib/python2.5/site-packages/openerp-server/addons/report_openoffice/__init__.py", line 29, in <module>
import report_openoffice
File "/usr/lib/python2.5/site-packages/openerp-server/addons/report_openoffice/report_openoffice.py", line 39, in <module>
from DocumentConverter import DocumentConverter
File "/usr/lib/python2.5/site-packages/openerp-server/addons/report_openoffice/DocumentConverter.py", line 23, in <module>
import unohelper
File "/usr/lib/python2.5/site-packages/uno.py", line 262, in _uno_import
return _g_delegatee( name, *optargs, **kwargs )
File "/usr/lib/python2.5/site-packages/unohelper.py", line 36, in <module>
from com.sun.star.lang import XTypeProvider, XSingleComponentFactory, XServiceInfo
File "/usr/lib/python2.5/site-packages/uno.py", line 278, in _uno_import
RuntimeException = pyuno.getClass( "com.sun.star.uno.RuntimeException" )
RuntimeError: pyuno.getClass: expecting one string argument

Any help/ suggestion please

Regards Rinaldo

Re: Error installing report_openoffice

PostPosted: Tue Mar 31, 2015 9:49 am
by longwest
Did you solve it now? hope you can share your solution with me, it will be much appreciated.