Ubuntu 14.04 Exception

Ubuntu 14.04 Exception

Postby Jordan » Fri Aug 22, 2014 2:31 pm

Hi,

I was quite happily using aeroo reports on Ubuntu 12.04 with OpenERP 6.1 but when I upgraded my development PC to Ubuntu 14.04 I started to get trouble.
Ubuntu 14.04 does not supply python-uno anymore but provides libreoffice-script-provider-python.
I cannot get libreoffice to work with aeroo_reports_ooo unless I install OpenOffice-4.1 and set:
PYTHONPATH=$PYTHONPATH:/opt/openoffice4/program
export PYTHONPATH
in my ~openerp/.bashrc
Weather I use OpenOffice or LibreOffice if my PYTHONPATH is as above it seems to work with some caveats. For every report I get the same error in the OpenERP log.
2014-08-22 11:20:37,330 25441 INFO openerp_pilot openerp.addons.report_aeroo.report_aeroo: registering report.rma_geicp_invoice_report (rma.geicp) (openerp_pilot)
Traceback (most recent call last):
File "/home/gjordan/Projects/OpenERP/addons-extra-6.1/report_aeroo/report_xml.py", line 247, in register_all
OpenOffice_service(cr, host, port)
File "/home/gjordan/Projects/OpenERP/addons-extra-6.1/report_aeroo_ooo/report.py", line 41, in __init__
DocumentConverter.__init__(self, host, port, ooo_restart_cmd)
File "/home/gjordan/Projects/OpenERP/addons-extra-6.1/report_aeroo_ooo/DocumentConverter.py", line 136, in __init__
raise DocumentConversionException("Not possible to accept on a local resource (%s)" % exception)
File "/opt/openoffice4/program/uno.py", line 306, in _uno_struct__repr__
return repr(self.__dict__["value"])
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-16: ordinal not in range(128)

I think this is 2 errors.
1, Connection to the socket
2, Some UnicodeEncodeError
I can telnet to localhost 8100 and get the result as explained in the several documents related to installing aerro reports, so why do I get this error above?
However I still seem to be able to run the reports?

Is there anything I can do to fix these errors from the logs?
Is there some way I can use the native Ubuntu libreoffice-script-provider-python?
What do I need to change in the code?

Many thanks for a great reporting tool.
Appreciate your help.

Grahame
Jordan
 
Posts: 1
Joined: Fri Aug 22, 2014 2:10 pm

Re: Ubuntu 14.04 Exception

Postby Faa » Fri Sep 19, 2014 5:32 pm

It's a big problem

It apears with me too and I don't know if the problem is related with OpenERP or OpenOffice or Aeroo Modules,

Anyway this problem of 'ascii' decoding are there and I don't if the problem is the object passed in repr function or the result of repr.

Is there a way to solve this problem please !! we are on openerp 7.0 and Ubuntu 14.04 64 bit and python 2.6.

My mail is vim6574@gmail.com and I will help you because I worked well on Aeroo but Ubuntu 12.04 32bits

Thank you Alistek :)
Faa
 
Posts: 3
Joined: Fri Sep 19, 2014 5:25 pm


Return to Aeroo Reports & OpenOffice.org Reporting Engine

cron
Copyright © 2001 Alistek Ltd., ALL RIGHTS RESERVED